const regex = /(^[0]|^[1-9]+)\.\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[0]|^[1-9]+)\\.\\d{2}$', 'gm')
const str = `0.01
122343.10
01.01
123,432.10
123
123423.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}