$re = '/(^[0]|^[1-9]+)\.\d{2}$/m';
$str = '0.01
122343.10
01.01
123,432.10
123
123423.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);