use strict;
my $str = 'Juan Ponce de León sights Florida for the first time, on 3.27, 1513
Giovanni da Verrazzano explored the Atlantic coast of North America under French employ, on 4.17.1524
The Roanoke Colony was found deserted, on 8/15/1590
John Smith founded the Jamestown settlement, on 5/14, 1607
The Dutch laid claim to the territories of New Netherland, on 11.11.1614
The Massachusetts Bay Colony founded, on 3-4-1629';
my $regex = qr/(\d{1,4}).(\d{1,4}).(\s?\d{4})/mp;
my $subst = '$3-$1-$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";