#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*Referer:(http(s)?(:\/\/))?(www\.)?test.com(\/.*)?).*$"
Local $sString = "Referer:http://www.test.online/" & @CRLF & _
"Referer:https://www.test.online/" & @CRLF & _
"Referer:https://www.test.tv/" & @CRLF & _
"Referer:https://www.blah.com/" & @CRLF & _
"Referer:https://www.test.com/" & @CRLF & _
"Referer:http://www.test.com/" & @CRLF & _
"Referer:http://test.com/" & @CRLF & _
"Referer:https://test.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")