re = /^(?!.*Referer:(http(s)?(:\/\/))?(www\.)?test.com(\/.*)?).*$/m
str = 'Referer:http://www.test.online/
Referer:https://www.test.online/
Referer:https://www.test.tv/
Referer:https://www.blah.com/
Referer:https://www.test.com/
Referer:http://www.test.com/
Referer:http://test.com/
Referer:https://test.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end