const regex = /#[\w-]++(?<!#hashtag|#DoNotRemoveThis)(?=(?:\s+#[\w-]+)*\s*$)\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#[\\w-]++(?<!#hashtag|#DoNotRemoveThis)(?=(?:\\s+#[\\w-]+)*\\s*$)\\s*', 'g')
const str = `Any #hashtag in the middle of the string should NOT be removed regardless of what it is, for example #DoNotRemoveThis #KeepThisHashtag #toto and any hashtag at the end of the string should be removed UNLESS it matches the exeptions in the regex. #deletethis #DoNotRemoveThis #thismustgoaway`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);