# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"#[\w-]++(?<!#hashtag|#DoNotRemoveThis)(?=(?:\s+#[\w-]+)*\s*$)\s*"
test_str = "Any #hashtag in the middle of the string should NOT be removed regardless of what it is, for example #DoNotRemoveThis #KeepThisHashtag #toto and any hashtag at the end of the string should be removed UNLESS it matches the exeptions in the regex. #deletethis #DoNotRemoveThis #thismustgoaway"
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.