using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":(::|[^:\n])+:";
string input = @":any-non-whitespace:
:text1:sample2:
:@(1@#$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}