import re
regex = re.compile(r":(::|[^:\n])+:")
test_str = (":any-non-whitespace:\n"
":text1:sample2:\n"
":@(1@#$@SD: :s:\n"
":nospace::inbetween: because there are 2 colons in the middle\n"
":nospace:middle:nospace:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")