package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:([a-zA-Z]+|)\d+([a-zA-Z]+|))`)
var str = `a1b2`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}