$re = '/abc\[(?=[^][]*z)(?=[^][]*4)(?=[^][]*\?)(?=[^][]*;)(?=[^][]*\*)[z*4?;]+]def/m';
$str = 'abc[4;?;z;*]def
abc[4?z*]def
abc[4?z;]def
abc[4;z*]def
abc[;z*]def';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);