re = /abc\[(?=[^][]*z)(?=[^][]*4)(?=[^][]*\?)(?=[^][]*;)(?=[^][]*\*)[z*4?;]+]def/m
str = 'abc[4;?;z;*]def
abc[4?z*]def
abc[4?z;]def
abc[4;z*]def
abc[;z*]def'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end