$re = '/Manufacturer:\s(?<Manufacturer>.*)/';
$str = '002446fffd003274.2:
Label: Back Door Lock
Manufacturer: Kwikset
Model: SMARTCODE_DEADBOLT_5
Firmware version: 0x3071cb06
Hardware version: 3
User Properties:
NearEndRssi: -41
NearEndLqi: 243
label: Back Door Lock
deadboltJammed: false
Battery Operated: True
Voltage: 5.8V
FE radio: -67/254
NE radio: -41/243
Date added: Thu Oct 27 08:02:42 CDT 2016
Date of last communication: Mon Feb 13 14:15:14 CST 2017
In Communication Failure: false
In firmware upgrade failure: false
Firmware upgrade available: false
Is Locked: true
Max Users: 30
Operation Mode: normal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);