# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Manufacturer:\s(?<Manufacturer>.*)"
test_str = ("002446fffd003274.2:\n"
" Label: Back Door Lock\n"
" Manufacturer: Kwikset\n"
" Model: SMARTCODE_DEADBOLT_5\n"
" Firmware version: 0x3071cb06\n"
" Hardware version: 3\n"
" User Properties:\n"
" NearEndRssi: -41\n"
" NearEndLqi: 243\n"
" label: Back Door Lock\n"
" deadboltJammed: false\n"
" Battery Operated: True\n"
" Voltage: 5.8V\n"
" FE radio: -67/254\n"
" NE radio: -41/243\n"
" Date added: Thu Oct 27 08:02:42 CDT 2016\n"
" Date of last communication: Mon Feb 13 14:15:14 CST 2017\n"
" In Communication Failure: false\n"
" In firmware upgrade failure: false\n"
" Firmware upgrade available: false\n"
" Is Locked: true\n"
" Max Users: 30\n"
" Operation Mode: normal")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.