package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Apple f.*m`)
var str = `Apple f2 m
Apple f2 t
Apple f3 m
Apple f3 t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}