$re = '/Apple f.*m/';
$str = 'Apple f2 m
Apple f2 t
Apple f3 m
Apple f3 t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);