package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^deck\s*:?\s*(?<deckname>.*)`)
var str = `deck: Base A
Deck: Base A
deck: Base A
DECK : Base A
deck BASE A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}