#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)({"id.+?t;\\"})"
Local $sString = "{"note\":null,\"cart_level_discount_applications\":[]};\n MAKEBECOOL_BUNDLES.product = {"id\":7148755124373,\"title\":\"Couch Jumper White 6 Pack\",\"handle\":\"couch-jumper-white-6-pack\",\"description\":\"\\u0026lt;p\\u0026gt;Ultra-comfortable, "variants": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\u0026lt;\\\/p\\u0026gt;\"};\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")