$re = '/({"id.+?t;\\\\"})/m';
$str = '{"note\\":null,\\"cart_level_discount_applications\\":[]};\\n MAKEBECOOL_BUNDLES.product = {"id\\":7148755124373,\\"title\\":\\"Couch Jumper White 6 Pack\\",\\"handle\\":\\"couch-jumper-white-6-pack\\",\\"description\\":\\"\\\\u0026lt;p\\\\u0026gt;Ultra-comfortable, "variants": anti-bacterial socks You’re gonna love them as much as we do! Guaranteed!\\\\u0026lt;\\\\\\/p\\\\u0026gt;\\"};\\n MAKEBECOOL_BUNDLES.isPhysicalBundle = true;\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);