import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(ایران)?(\\d{2})(?:-|,| )(\\d{3})([ آابپتثجچحخدذرزژسشصضطظعغفقکگلمنوهی]{1})(\\d{2})";
        final String string = "ایران48-279ع17\n"
	 + "48-279ع17\n"
	 + "ایران48,279ع17 \n"
	 + "48,279ع17 \n"
	 + "ایران48 279ع17 \n"
	 + "48 279ع17 ";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}