import re
regex = re.compile(r"[0-9]{2} ?([05][1-9]|[16][02]) ?(0[1-9]|[12][0-9]|3[0-1]) ?\/?[0-9]{3,4}")
test_str = ("821206/0351 \n"
"82 12 06 0351 \n"
"721206 0351 \n"
"82 82 23/3222 \n"
"82 52 12/342\n"
"825212342\n"
"82 61 45 2222\n"
"821206 0351")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")