package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)\s*(/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)?`)
var str = `var1 /* first, variable */, var2, var3 /* third, variable */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}