re = /(\w+)\s*(\/\*[^*]*\*+(?:[^\/*][^*]*\*+)*\/)?/
str = 'var1 /* first, variable */, var2, var3 /* third, variable */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end