re = /(?:What is|plus|minus|multiplied by|divided by)|(\S+)/m
str = 'What is plus abc divided by'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end