using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"chapter [0-9].*?(?=chapter [0-9]|\Z)";
string input = @"chapter 1 Here is a block of text from chapter one. chapter 2 Here is another block of text from the second chapter. chapter 3 Here is the third and final block of text.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}