re = /chapter [0-9].*?(?=chapter [0-9]|\Z)/m
str = 'chapter 1 Here is a block of text from chapter one. chapter 2 Here is another block of text from the second chapter. chapter 3 Here is the third and final block of text.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end