const regex = /(?<!\d)\d{7}(?!\d)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\d)\\d{7}(?!\\d)', 'g')
const str = `1234567A XYZ1234567A 12345678 XYZ12345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}