$re = '/(?<!\d)\d{7}(?!\d)/';
$str = '1234567A XYZ1234567A 12345678 XYZ12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);