$re = '/(?:.*?)(\b\w.{3,}\b)(?:.*?)(\1)/uis';
$str = 'I want a dog
A dog** is here
Pet a dog
A red cat
red cat is cute';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);