import re
regex = re.compile(r"(?:.*?)(\b\w.{3,}\b)(?:.*?)(\1)", flags=re.UNICODE | re.IGNORECASE | re.DOTALL)
test_str = ("I want a dog \n"
"A dog** is here\n"
"Pet a dog\n"
"A red cat\n"
"red cat is cute")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")