const regex = new RegExp('^(\\d+(?:\\.\\d+)+ +- +\\d{4}-\\d{2}-\\d{2})\\r?\\n((?:(?!\\d+\\.\\d).*(?:\\r?\\n|$))*)', 'gm')
const str = `##################
Some texts
4.11.1 - 2020-02-25
-------------------
*some text
** Some more text
3.25.0 - 2019-01-01
-------------------
*some text
** Some more text
.com/sth/sth/sth/6)
1.8.2 (https://github.com/sth/sth/sth/5)
1.8.1.
20160918 (see commands under 'some text')
. text text tex`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}