import re
regex = re.compile(r"^(\d+(?:\.\d+)+ +- +\d{4}-\d{2}-\d{2})\r?\n((?:(?!\d+\.\d).*(?:\r?\n|$))*)", flags=re.MULTILINE)
test_str = ("##################\n"
"Some texts\n\n"
"4.11.1 - 2020-02-25\n"
"-------------------\n\n"
"*some text\n\n"
"** Some more text\n\n"
"3.25.0 - 2019-01-01\n"
"-------------------\n\n"
"*some text\n\n"
"** Some more text\n\n"
".com/sth/sth/sth/6)\n\n"
"1.8.2 (https://github.com/sth/sth/sth/5)\n\n"
"1.8.1.\n\n"
"20160918 (see commands under 'some text')\n\n"
". text text tex")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")