$re = '/.*\.fritz\.box$/m';
$str = 'meineServer.fritz.box';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);