using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![Ii]s)a{2,}";
string input = @"Lorem ipsum dolor sit aamet, consectetur aaadipiscing elit, Isaac sed do eiusmod tempor incididunt ut labore et dolore magnaaa aliqua. Ut enim ad minim veniaaaam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat, isaac. Duis aaaaaaute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nullaaaa pariatur. Isaac excepteur sint occaecat cupidatat non proident, sunt in culpaa qui officia deserunt mollit anim id est laborum.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}