package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<user>[a-zA-Z0-9._%+'-]+)@(?<domain>[a-zA-Z0-9.'-]+\.[a-zA-Z]{2,4})$`)
var str = `d'artagnan@maisonduroi.gov.fr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}