re = /^(?<user>[a-zA-Z0-9._%+'-]+)@(?<domain>[a-zA-Z0-9.'-]+\.[a-zA-Z]{2,4})$/m
str = 'd\'artagnan@maisonduroi.gov.fr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end