import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((apple|orange|tomato)\\.)+?\\w*?[^\\.]$";
final String string = "apple.orange.tomato.COULD_BE_ANY_STRING_HERE\n"
+ "apple.orange.tomato.COULD_BE_ANY_STRING_HERE.\n"
+ "apple.orange.tomato.\n"
+ "apple\n"
+ "orange\n"
+ "apple.orange.tomato.COULD_BE_ANY_STRING_HERE_SOMETHING_ELSE\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}