$re = '/^((apple|orange|tomato)\.)+?\w*?[^\.]$/im';
$str = 'apple.orange.tomato.COULD_BE_ANY_STRING_HERE
apple.orange.tomato.COULD_BE_ANY_STRING_HERE.
apple.orange.tomato.
apple
orange
apple.orange.tomato.COULD_BE_ANY_STRING_HERE_SOMETHING_ELSE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);