import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{8,10}[^a-zA-Z\\s])$";
final String string = "This is a number also 123-456-7890\n"
+ "This is not a number: 123456\n"
+ "This is not a number, but an address 123 456\n"
+ "My parameters are 90/60/90 - 120/150/120 - not a phone number\n"
+ "I am cheeky and I use letter 0 instead of zero 604_213_0293 Or I use | symbol\n"
+ "and also 604_2|3_0293 may happen\n"
+ "The most classical Canadian number is +1(604)123-4567 hi hi\n"
+ "Dashes can be different 123-456–7890\n"
+ "And looks like phone +I(800)-2l4-15O but contain combination with letter\n\n"
+ " 'oi+I(222)3334444oi',\n"
+ " 'io+0 (222) 333 444Ooi',\n"
+ " 'O+l ( 222 ) 3|3 4O40O',\n"
+ " '+O+l ( 222 ) 3|3 4O40O',\n"
+ "069123521\n"
+ "0691235523\n"
+ "06912355312\n"
+ "in text 123-567\n"
+ "+(1)-23567 text\n"
+ "in text 123567-2 text\n\n"
+ "---------------------------------------\n\n"
+ "in text 1-800-123-123\n"
+ "1-800-123-123 text\n"
+ "in text 1-800-123-123 text\n\n"
+ "---------------------------------------\n\n"
+ "in text 1-800-123-123\n"
+ "1-800-123-123 text\n"
+ "in text 1-800-123-123 text\n\n\n"
+ "---------------------------------------\n"
+ "n0OOOOOOOOOOOO\n\n"
+ "h1iiiiiiiiiiiii\n\n"
+ "in text +l-800-123-123\n"
+ "1-8oo-I23-i23 text\n"
+ "in text +1 (800)-l23-123 text\n\n"
+ "phone\n"
+ " '012345678',\n"
+ " '0123456789',\n"
+ " '01234567891',\n"
+ " '012345678912',\n"
+ " '0123456789123',\n"
+ " '01234567891234',\n"
+ " '012345678912345',\n"
+ " '800-1234567',\n"
+ " '8Oo-I234567-l',\n"
+ " '+1(222)3334444',\n"
+ " '+1 (222) 333 4444',\n"
+ " '+1 ( 222 ) 333 4444',\n"
+ " '+1-222-333-4444',\n"
+ " '+1 222 333 4444',\n"
+ " '236 - 332 - 6669',\n"
+ " '(604)123-4567',\n"
+ " '604 123 4567',\n"
+ " '604_123_4567',\n"
+ " '2368337551',\n"
+ " '12223334444',\n"
+ " '222) 333 4444',\n"
+ " '3333 4444',\n"
+ " '(437)1234567',\n"
+ " '(888)1234123',\n\n"
+ "not a phone\n"
+ " '0',\n"
+ " '01',\n"
+ " '012',\n"
+ " '0123',\n"
+ " '01234',\n"
+ " '012345',\n"
+ " '0123456',\n"
+ " '01234567',\n"
+ " '90-60-90',\n"
+ " '90/60/90',\n"
+ " '0123456789123456',\n"
+ " '+X (XXX) XXX XXXX',\n"
+ " '1/23-4',\n"
+ " '1 / 23 - 4',\n"
+ " '1234/12,3-1234'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}