# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-9]{8,10}[^a-zA-Z\s])$"
test_str = ("This is a number also 123-456-7890\n"
"This is not a number: 123456\n"
"This is not a number, but an address 123 456\n"
"My parameters are 90/60/90 - 120/150/120 - not a phone number\n"
"I am cheeky and I use letter 0 instead of zero 604_213_0293 Or I use | symbol\n"
"and also 604_2|3_0293 may happen\n"
"The most classical Canadian number is +1(604)123-4567 hi hi\n"
"Dashes can be different 123-456–7890\n"
"And looks like phone +I(800)-2l4-15O but contain combination with letter\n\n"
" 'oi+I(222)3334444oi',\n"
" 'io+0 (222) 333 444Ooi',\n"
" 'O+l ( 222 ) 3|3 4O40O',\n"
" '+O+l ( 222 ) 3|3 4O40O',\n"
"069123521\n"
"0691235523\n"
"06912355312\n"
"in text 123-567\n"
"+(1)-23567 text\n"
"in text 123567-2 text\n\n"
"---------------------------------------\n\n"
"in text 1-800-123-123\n"
"1-800-123-123 text\n"
"in text 1-800-123-123 text\n\n"
"---------------------------------------\n\n"
"in text 1-800-123-123\n"
"1-800-123-123 text\n"
"in text 1-800-123-123 text\n\n\n"
"---------------------------------------\n"
"n0OOOOOOOOOOOO\n\n"
"h1iiiiiiiiiiiii\n\n"
"in text +l-800-123-123\n"
"1-8oo-I23-i23 text\n"
"in text +1 (800)-l23-123 text\n\n"
"phone\n"
" '012345678',\n"
" '0123456789',\n"
" '01234567891',\n"
" '012345678912',\n"
" '0123456789123',\n"
" '01234567891234',\n"
" '012345678912345',\n"
" '800-1234567',\n"
" '8Oo-I234567-l',\n"
" '+1(222)3334444',\n"
" '+1 (222) 333 4444',\n"
" '+1 ( 222 ) 333 4444',\n"
" '+1-222-333-4444',\n"
" '+1 222 333 4444',\n"
" '236 - 332 - 6669',\n"
" '(604)123-4567',\n"
" '604 123 4567',\n"
" '604_123_4567',\n"
" '2368337551',\n"
" '12223334444',\n"
" '222) 333 4444',\n"
" '3333 4444',\n"
" '(437)1234567',\n"
" '(888)1234123',\n\n"
"not a phone\n"
" '0',\n"
" '01',\n"
" '012',\n"
" '0123',\n"
" '01234',\n"
" '012345',\n"
" '0123456',\n"
" '01234567',\n"
" '90-60-90',\n"
" '90/60/90',\n"
" '0123456789123456',\n"
" '+X (XXX) XXX XXXX',\n"
" '1/23-4',\n"
" '1 / 23 - 4',\n"
" '1234/12,3-1234'")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.