$re = '/^\s*(?:from|import)\s+(\w+(?:\s*,\s*\w+)*)/m';
$str = 'import os
import numpy as np
from itertools import accumulate
from collections import Counter as C
from pandas import *
s="""this is a present from me"""
import re, csv, pandas';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);