// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(?:from|import)\s+(\w+(?:\s*,\s*\w+)*)").unwrap();
let string = "import os
import numpy as np
from itertools import accumulate
from collections import Counter as C
from pandas import *
s=\"\"\"this is a present from me\"\"\"
import re, csv, pandas";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}