$re = '~/\*<<@\*/(?:(?!/\*).)*?/\*+[^*]*\*+(?:[^/*][^*]*\*+)*/*~';
$str = 'DECLARE @myDate DATETIME = /*<<@*/ \'2018-07-20 00:00:00\' /*My Date>>*/
DECLARE @myString VARCHAR(MAX) = /*<<@*/ \'whatever?\' /*My String>>*/ DECLARE @isTrue VARCHAR(MAX) = /*<<@*/ 1 /*My Bool>>*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);