re = /\/\*<<@\*\/(?:(?!\/\*).)*?\/\*+[^*]*\*+(?:[^\/*][^*]*\*+)*\/*/
str = 'DECLARE @myDate DATETIME = /*<<@*/ \'2018-07-20 00:00:00\' /*My Date>>*/
DECLARE @myString VARCHAR(MAX) = /*<<@*/ \'whatever?\' /*My String>>*/ DECLARE @isTrue VARCHAR(MAX) = /*<<@*/ 1 /*My Bool>>*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end