#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?:[a-zA-Z0-9]{8,})$"
Local $sString = "Sh0rter" & @CRLF & _
"N0LOWERCASE" & @CRLF & _
"n0uppercase" & @CRLF & _
"noLetters" & @CRLF & _
"This15OK" & @CRLF & _
"val1dOne" & @CRLF & _
"longer1sOkNo" & @CRLF & _
"NoSpecia1Chars?" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")