$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?:[a-zA-Z0-9]{8,})$/m';
$str = 'Sh0rter
N0LOWERCASE
n0uppercase
noLetters
This15OK
val1dOne
longer1sOkNo
NoSpecia1Chars?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);