use strict;
my $str = '<p><em>Hi [User</em></p>
<p><em>Tack för visat intresse.</em></p>
<p><em>Good luck!</em><em> </em></p>
<p><em>Sincerely</em></p>';
my $regex = qr/(?<!\<)[^<>\s](?!\>)/mp;
my $subst = 'n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";