re = /(?<!\<)[^<>\s](?!\>)/m
str = '<p><em>Hi [User</em></p>
<p><em>Tack för visat intresse.</em></p>
<p><em>Good luck!</em><em> </em></p>
<p><em>Sincerely</em></p>'
subst = 'n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result