import re
regex = re.compile(r"\d+\K\d{3}(?=\h£)")
test_str = ("2015 64 Fiat 500 S Hatchback 1.2 Manual Petrol Silver White 13000 £7,495\n"
"2012 12 Fiat 500 Lounge Hatchback 1.2 Manual Petrol White 9000 £5,495\n"
"2014 14 Fiat Panda Pop Hatchback 1.2 Manual Petrol White 30000 £4,695\n"
"2009 09 Fiat 500 Pop Hatchback 1.2 Manual Petrol Yellow 31000 £4,295")
subst = ",$0"
result = regex.sub(subst, test_str)
if result:
print(result)