const regex = /([1-9]|0[1-9]|1[0-2])\/([1-9]|0[1-9]|1\d|2\d|3[01])\/(((19|2[0-4])\d{2})|2500)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9]|0[1-9]|1[0-2])\\\/([1-9]|0[1-9]|1\\d|2\\d|3[01])\\\/(((19|2[0-4])\\d{2})|2500)', 'g')
const str = `Dates between 1900 to 2500
12/1/2400
01/1/2001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}